Loading…
Tilbage

Profilbillede

Får fejl i integration med eID og OIOSAML.java (v. 2.2.1)

Michael Lerskov

Efter at have opgraderet til OIOSAML.java (v 2.2.1) https://www.digitaliser.dk/resource/5359238 oplever vi fejl i eID integrationen.

Når en borgere logger på med eID og OIOSAML skal behandle responset får vi følgende exception.
"java.lang.RuntimeException: Assurance level too low: 0, required: 2"

Vi har, i vores testmiljø, forsøgt at sætte required assuance level til 0, uden at det virkede (det er heller ikke en løsning vi kan anvende i produktion).

Er der andre der oplevere tilsvarende problemer? Og er der nogen der har en løsning på det?

ændret af Michael Lerskov (08.04.2021)

Hej Michael,

jeg fejlmeldte en lign. fejl her https://www.digitaliser.dk/forum/5942514, du kan se om svaret jeg fik også vil hjælpe jer.

Hej Jack

Det prøver vi at kigge på - tak.


Vh
Michael

ændret af Michael Lerskov (09.04.2021)

Kære Michael,

Jeg beklager at vi ikke har fået svaret før nu og jeg kan desværre kun sige at vi er i gang med at undersøge problemet og selvfølgelig løsningen.

Har du mulighed for at sende os responset og assertion (dekrypteret) på eidas@digst.dk og cc mig på thokm@digst.dk?

Eftersom i får en fejl med assurance level selv efter skiftet er vores hypotese, at det skyldes at den ikke kan parse resultatet og blot giver en lidt for generisk fejl. 

Vi har også set ændringerne igennem til OIOSAML.java 2.2.1 og kan ikke umiddelbart se at der skulle have været ændringer som kunne give ovenstående fejl, men vi undersøger det alligevel da i sandsynligvis ikke vil være de eneste.

Jeg vender tilbage med en opdatering hurtigst muligt og i hvert fald i den kommende uge.

Med venlig hilsen,

Thoke

ændret af Thoke Graae Magnussen (18.04.2021)